My kemenworld…

To mock or not to mock…

El fin de PHP como muchos lo conocen

Posted by kementeus en agosto 17, 2007

Hace unos meses atrás hablaba con alguien que me contaba lo feliz que se sentia al lograr que aprobaran el uso de “ciertas” librerías PEAR en su trabajo, esto ayudaría a ampliar grandemente su kit de herramientas de trabajo. Claro, le dijeron que si al uso de librerías PEAR pero rebotaron y de forma definitiva su petición para desarrollar sitios en PHP5. Cuando este compañero me conto sobre el caso le comenté sobre la desición de la organización PEAR de no soportar a partir del 1 de enero del año 2008 a cualquier librería que dependiera de PHP menor a la versión 5.0 (http://pear.php.net/news/package.xml.1.0.php), resulta que aunque ya muchos lo veiamos venir, ahora es oficial el anuncio de parte de PHP, a partir del 1 de enero del 2008 tampoco será “soportado” versiones de PHP anteriores a la versión 5, por lo que recomiendan portar sus aplicaciones a la versión 5 como mínimo, (la noticia en la pagina principal de php http://www.php.net). Creo que es ahora un buen momento no solo para portar sus respectivas aplicaciones a PHP5 (que en mi criterio es ahora un lenguaje “muy compentente”) sino también para aprender buenas prácticas en cuanto a técnicas de desarrollo de aplicaciones web.

3 comentarios to “El fin de PHP como muchos lo conocen”

  1. Marco Villatoro said

    Hola Cristian, en un par de oportunidades he asistido a las charlas del grupo de programadores .NET y me he dado cuenta que dominas muy bien este tema.
    Mi fuerte no son los productos de Microsoft, sin embargo me ha llamado mucho la atencion el Visual Basic, aunque nunca he utilizado este lenguaje para desarrollar una aplicacion completa, la verdad si quisiera entrar un poco mas al tema.
    Pero me realmente cuando veo el tipo de charlas que ustedes dan me he dado cuenta que son de un nivel “avanzado” para los que no conocemos muy bien el tema.
    Mi pregunta es, vos tenes alguna academia o impartis algun curso para enseñar a programar en VB..?? Y si es asi… cuales son los precios por un curso…??? Desde principiante hasta nivel avanzado.
    cualquier noticia que me podas proporcionar te la agradeceria a mi correo.
    Gracias y hasta luego.

  2. PHP4 dejó de existir hace mucho. PHP5 es una necesidad desde ese hace mucho. El que a esta altura no haya comenzado a migrar (mínimo a aprender PHP5) quedará obsoleto

  3. RF said

    Hola, me interesa este tema de librerías pear y php porque me estoy viendo venir un problema; me he encontrado una web casi hecha, en la que han metido mano diferentes programadores en distintas épocas; a mi me toca acabarla y colgarla pero nunca he utilizado php y pear hasta ahora; se utilizan librerías de pear que están deprecated y php5: mi pregunta es¿tendremos problemas para colgar por tener esas librerías? ¿habrá incompatibilidades graves o es cuestión pura y dura de actualizaciones? muchas gracias por las respuestas

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

 
A %d blogueros les gusta esto: